推荐个好用的机器人

发布于 2022-07-09  75 次阅读


我就一纯纯原批

Github上逛到的大佬项目,短暂使用了20天(小号就被风控了...)。功能很全,分享一下
Github原帖: 小派蒙
作者博客原帖: 小派蒙

机器人大概功能

详情见原连接

安装注意事项

作者写的教程是基于Centos系统
Centos自带python版本过低,需要更新版本换软链
但是由于Centos已经跑路了,该机器人基于的nonebot2框架制作者们好像已经润去ubuntu
部署完毕,下载依赖的时候。后台执行的是ubuntu的命令,而不是Centos的
所以不建议使用Centos系统搭建...
腾讯云的ubuntu镜像自带的python版本就已经符合要求了,甚至不需要你换软链(它真的,我哭死)

如果服务器暂时只能用Centos,建议安装老版本nb
github原链接: Nonebot2

另外扯几个常见报错

报错

由于我截图丢了(

所以凑合看

No.1

ModuleNotFoundError: No module named ‘_ssl‘

原因: python缺少运行库
解决方法参考: ModuleNotFoundError: No module named ‘_ssl‘
方法:安装以下依赖后重新编译安装python
如果遇到已安装等提示,跳过接着装下一个就行,能装的都装了
如果是ubuntu记得换apt

yum -y install zlib zlib-devel
yum -y install bzip2 bzip2-devel
yum -y install ncurses ncurses-devel
yum -y install readline readline-devel
yum -y install openssl openssl-devel
yum -y install openssl-static
yum -y install xz lzma xz-devel
yum -y install sqlite sqlite-devel
yum -y install gdbm gdbm-devel
yum -y install tk tk-devel
yum -y install libffi libffi-devel

No.2

WARNING: Running pip as the ‘root‘ user can result in broken permissions and conflicting

原因: pip操作使用root用户可能会造成损害,所以要进入虚拟环境
解决方法参考:WARNING: Running pip as the ‘root‘ user can result in broken permissions and conflicting
方法:进入虚拟环境后重新pip即可

No.3

大概率是你安装完python,换完软链之后忘了没换pip的软链


摸鱼ing